https://netmaker.org logo
Netmaker could not connect to broker
# server
t
Netmaker could not connect to broker
Issue: Netmaker Server won't start Error Messages (from log files): Netmaker: "Fatal: Admin: could not connect to broker, token timeout" Traefik: "Error while connecting to backend: dial tcp 172.18.0.5:8883: connect: connection refused" "unable to generate a certificate for the domains ... Error getting validation data" MQ: "Waiting for netmaker server to startup" Instructions for reproduction: Follow the steps described on github.com/gravitl/netmaker under "Get Started in 5 Minutes" (run "wget -qO - https://raw.githubusercontent.com/gravitl/netmaker/master/scripts/nm-quick.sh | sudo bash" on any VM with Ubuntu 20.04, a public IP and a firewall which allows access via ports 443 and 51821-1830 on it Key Notes: The issue doesn't exist for v0.14.6, but does exist for both v0.16.1 and v0.16.2.
It's the same issue I was having last week, but since I've misdiagnosed the issue before, the previous thread is no longer relevant (so I've decided to create a new and concise thread) Is the connection to the broker related to the certification issue? Can't Netmaker, MQ and Traefik communicate locally in an unsecured way instead? Or is the "connection refused" part caused by something else?
8 Views